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Included with this supplement are the following documents, reproduced and distributed as part of
a license agreement between G. H. Gillespie Associates, Inc. and the Board of Trustees of the
Leland Stanford Junior University (“STANFORD”):

Appendix A:  “NPSOL User’s Guide”

User’s Guide for NPSOL (Version 4.0), by Philip E. Gill, Walter Murray, Michael A. Saunders
and Margaret H Wright.

Department of Operations Research Stanford University Technical Report SOL 86-2,
January 1986.
Reproduced for distribution with PBO Lab by permission.

Appendix B:  “MINOS User’s Guide”

MINOS 5.4 User’s Guide, by Bruce A. Murtagh and Michael A. Saunders.
Department of Operations Research Stanford University Technical Report SOL 83-20R,
December 1986, Revised Jan 1987, Mar 1993, Feb 1995.
Reproduced for distribution with PBO Lab by permission.

Appendix C:  “LSSOL User’s Guide”

User’s Guide for LSSOL (Version 1.0), by Philip E. Gill, Sven J. Hammarling, Walter Murray,
Michael A. Saunders and Margaret H Wright.

Department of Operations Research Stanford University Technical Report SOL 86-1,
January 1986.
Reproduced for distribution with PBO Lab by permission.

DISCLAIMER NOTICE

STANFORD MAKES NO REPRESENTATIONS OF WARRANTIES, EXPRESSED OR
IMPLIED.  By way of example, but not limitation, STANFORD MAKES NO
REPRESENTATIONS OR WARRANTIES OF MERCHANTABILITY OR FITNESS FOR ANY
PARTICULAR PURPOSE OR THAT THIS USE OF MINOS and/or NPSOL WILL NOT
INFRINGE ANY PATENTS, COPYRIGHTS, TRADEMARKS, OR OTHER RIGHTS.
STANFORD shall not be LIABLE for liability or damages with respect to any claim by
LICENSEE or any third party on account of, or arising from the license, or an Use Sublicense(s)
of use of MINOS and/or NPSOL.
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NPSOL is a sophisticated nonlinear, constrained, optimization program
developed at Stanford University’s System Optimization Laboratory.  It uses a
sequential quadratic programming (SQP) algorithm that evaluates the gradient of
the objective function, and the Jacobian of the constraint functions, to determine
which variables should be varied next in the search, and then treats the problem
as a least squares optimization locally.  Constraints are satisfied first, and then the
code determines if an optimal (locally minimal) solution has been achieved.
NPSOL is designed to work on problems in which the variables are tightly
connected through linear and nonlinear constraints, e.g. in which the matrices
dealt with are dense.  

MINOS is designed to solve large-scale optimization problems that can include
linear and nonlinear constraints.  A system of methods and algorithms are
harmoniously combined to address small and large problems in four main
problem areas:  linear programming, unconstrained optimization, linearly
constrained optimization, and nonlinearly constrained optimization.  Advanced
versions of several classical optimization algorithms are included:  the simplex
method, a quas-Newtonian method, the reduced-gradient method, and a projected
Lagragian method.
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1.  Optimization Tool Module

The Optimization Tool Module for the Particle
B e a m O p t i c s L a b o r a t o r y c o m b i n e s t h r e e
optimization programs: LSSOL, NPSOL and MINOS
with a variety of charged particle optics and
accelerator simulation codes, all within a single
intuitive graphic user interface.  This combination
yields an advanced analysis and design tool that
offers users the ability to significantly improve the
optimization process by providing an environment to
easily formulate beamline optimization tasks, and to
solve problems in an intuitive way.  

An optimization problem is specified in terms of
variables, constraints and stored output parameters.
There are three types of constraints: linear,
nonlinear and the objective function.  The
optimization engine attempts to find values for the
variables that will satisfy the constraints.  

Optimization variables are selected from beamline
element parameters.  Linear constraints are defined
in terms of these Optimization Variables.  The
objective function and nonlinear constraints are
defined in terms of variables and stored output
parameters.  Stored output parameters, from PBO
Lab Application Modules (TRANSPORT and
TRACE 3-D) are selected by the user and computed
by the respective simulation codes.  

The Optimization Tool allows optimization problems
to be defined over multiple beamline Model
Documents and supports aliasing beamline elements
between Documents.  Multiple beamlines may share
(Alias) individual elements or entire beamline
segments.  The Optimization Tool can also be used in
combination with the fitting/matching capabilities of
individual Application Modules to perform a
hierarchal optimization problem.  

The Optimization Tool Module for the
Particle Beam Optics Laboratory
provides three optimization engines,
integrated with PBO Lab Application
Modules for charged particle optics
and accelerator simulations.  

LSSOL is a constrained linear least-
squares and quadratic optimization
program.  The NPSOL and MINOS
programs  are  both  constrained
nonlinear optimization programs.

Optimization problems are defined in
terms of user specified variables,
constraints and stored output
parameters.

Optimization variables and stored
output parameters are selected in
the beamline model and used to
define Optimization Constraints. 

Optimization problems can be
defined over multiple beamline Model
Documents and beamline elements
can be shared between Documents.

The Optimization Tool can also be
used for hierarchal optimization
using the native fitting/matching
capabilities of individual Application
Modules.  
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Multiple Model Mode

The Optimization Tool supports the specification of
an Optimization Problem that can share (Alias)
beamline elements between multiple beamline models
in separate Document Windows.  This Multiple
Model Mode is selected with a user preference as
illustrated in Figure 1.  To use the Optimization
Tool Module, the PBO Lab Preference for
Application Type must be set to Multiple Model
Mode.  This is the default setting when the
Optimization Tool Module is installed.  Figure 2
illustrates the Optimizer Problem Window that is
opened when the PBO Lab application is launched in
the Multiple Model Mode.  

If the PBO Lab Application Type Preference is set
to Single Model Mode then the Optimizer Problem
Window will not be opened and the standard
Document Window will be opened.  When you
change the Application Type Preference, PBO Lab
must be restarted in order for the change to take
effect.  Refer to the PBO Lab PreferencesSection in
the Analysis ToolsChapter of the PBO Lab User
Manual for a description of the Application Type
Preference.  

To use the Optimization Tool Module,
the PBO Lab Preference for
Application Type must be set to
Multiple Model Mode.  

PBO Lab must be restarted in order
for changes in the Application Type
Preference to take effect.  

The Application Type Preference is used 
to select the Multiple Model PBO Lab 

configuration (Multiple Document 
Mode) for Optimization Problems

The PBO Lab Preferences Window 
is accessed from the Tools Menu 

in any Document Window

Figure 1.  Application Type Preference - Single and Multiple Document Modes.  
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The Single Model Application Type (Single
Document Mode), is the standard configuration for
PBO Lab when the Optimization Tool is not
installed.  The Multiple Model Application Type
(Multiple Document Mode) modifies the user
interface so that a persistent link can be maintained
between multiple Document Windows, allowing
beamline elements to be shared (Aliased) between
separate beamlines.  The Optimizer Problem
Window, shown in Figure 2, contains a list of any
beamline Model Documents that are linked in the
Optimizer Problem.  Double-click a model in the
Problem Window to open the corresponding
beamline Model Document Window.  

The Single Model Application Type is
the standard configuration when the
Optimization Tool is not installed,
since most problems do not require
multiple beamline Model Documents
with shared (Aliased) beamline
elements.  

Multiple Beamline Model Documents can 
be used in a single Optimization Problem

Double-click the Model in the Problem 
Window to open individual Beamline 

Model Document Windows

Figure 2.  Optimizer Problem Window and Corresponding Document Windows.  
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The user interface for individual beamline Model
Document Windows is the same for both the Single
and Multiple Document configurations and is
described in the main PBO Lab User Manual.
However, the Optimizer Problem Window, which is
used in the Multiple Document Mode is described in
this Supplement.  

The Document Windows user
interface is the same for both the
Single   and   Multiple   Document
configurations and is described in
the main PBO Lab User Manual.  

Optimizer Problem Window

The Optimizer Problem Window is provided when
PBO Lab is setup in the Multiple Model Mode.  The
Multiple Model (Document) Mode is required to run
optimization problems, even for problems with
single beamline Model Document.  The Optimizer
Problem Window, shown in Figure 3, is used to
e x e c u t e t h e O p t i m i z a t i o n T o o l , e x a m i n e
Optimization Variables, Stored Parameters and
Constraints, as well as providing a means to define a
single Optimization Problem across multiple
beamline models.  

The Optimizer Problem Window is
used to organize multiple beamline
Document Windows for a single
Optimization Problem.  Document
Windows are used to graphically
construct beamlines, modify input
parameters,   select   optimization
variables   and   Stored   Output
Parameters.  

Optimizer Commands are accessed from the Tools 
Menu of the Optimizer Problem Window

All Beamline Model Documents for 
the Optimization Problem are listed 
in the Optimizer Problem Window

The Button Bar provides controls for 
frequently used features such as opening 
new Documents and linking elements 
between beamline model Documents

Figure 3.  Optimizer Problem Window.  
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Individual Document Windows, created and accessed
from the Problem Window are used to graphically
construct beamlines, modify input parameters, select
Optimization Variables and define application-
specific Stored Output Parameters.  The Problem
Window contains a Menu Bar, Button Bar and a
scrolling list of beamline Model Documents for the
Optimizer Problem.  

Optimization Engines
The PBO Lab Optimization Module includes three
optimization programs: LSSOL, NPSOL and
MINOS.  LSSOL is a constrained linear least-squares
and quadratic optimization program.  NPSOL and
MINOS are both constrained nonlinear optimization
programs, but the two packages use different
approaches and are applied to different types of
optimization problems.  LSSOL and NPSOL are a
collection of FORTRAN subroutines developed as a
Systems Optimization Laboratory (SOL) by the
Department of Operations Research at Stanford
University.  MINOS is also a FORTRAN code
developed at Stanford University.  LSSOL finds the
solution for a purely quadratic objective function,
with linear constraints.  NPSOL uses a sequential
quadratic programming (SQP) algorithm to address
more complicated nonlinear problems.  The SQP
algorithm evaluates the gradient of the objective
(Merit) function, and the Jacobian of the constraint
functions, to determine which of the variables should
be varied next in the search, and then treats the
problem as a least squares optimization locally.
Constraints are satisfied first, and then the code
determines if an optimal (locally minimal) solution
has been achieved.  MINOS was developed to solve
nonlinear optimization problems which use very
large sparse matrices in the representation of the
problem to be solved.   

The PBO Lab Optimization Module
includes three different optimization
programs:  LSSOL,  NPSOL  and
MINOS.  

MINOS addresses problems that can
be formulated in slightly more
general terms than available in
NPSOL. 
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C-language versions of all three optimization engines
have been integrated into the PBO Lab graphic user
interface and underlying beamline object model.
Any input parameter to a PBO Lab Application
Module (TRANSPORT, TURTLE, TRACE 3D or
MARYLIE) can be selected as an optimization
variable.  Stored diagnostic output parameters from
the different computational programs are used to
formulate the nonlinear constraints and/or merit
(objective) function for optimization.  

Optimization problems are completely defined using
the PBO Lab graphic user interface.  Although the
optimization programs are complex, the input
requirements for each are seamlessly integrated with
the different PBO Lab Application Modules in a
single easy-to-use graphic interface.  

Diagnostic output from the different computational
programs is dynamically shared with the different
optimization engines and optimization variables are
automatically updated in the beamline model during
the optimization process.  No user written functions
(FUNCON, FUNOBJ) are required to define an
optimization problem.  PBO Lab provides graphic
user interface windows for defining the Optimization
Objective (merit) function and Optimizer Constraint
functions.  Optimization Variables and Stored Output
Parameters are easily selected in the PBO Lab
graphic beamline representation, the same way
fitting variables and constraints are specified for the
different computational programs.  

Optimization problem setup is similar for each of the
optimization programs.  Although each has a
separate window for specifying objective and
constraint functions, these windows are very similar
in terms of the user interface.  

Inputs to PBO Lab Application
Modules are used as variables for
any of the optimizers, while the
outputs provide parameters to
formulate nonlinear constraints and
merit functions for optimization.  

There are no user written functions
required to define an optimization
problem in PBO Lab.  Graphic user
interface windows are provided for
s p e c i f y i n g t h e O p t i m i z a t i o n
Objective function and Constraint
functions.  Optimization Variables
and Stored Output Parameters are
easily selected in the PBO Lab
graphical beamline representation.  
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Setting up a problem for different optimization
engines  is  easy.  Optimization Variables and Stored
Output Parameters are setup in the beamline model
and are independent of the optimization program
selection.  

Each Optimization program has a corresponding
sub-menu in the Tools Menu and in the View Menu
of the Optimizer Problem Window.  The Tools sub-
menus contain the commands to Run a particular
optimization program.  Each sub-menu also contains
a Constrains command that is used to open the
Optimization Constraints Window for each of the
Optimization programs.  The NPSOL and MINOS
sub-menus also contain commands to access Watch
Setup Windows that are used to select Watch Values
from among the Optimization Variables and
constraints.  These selections will be displayed
dynamically in a Watch Window during the
optimization process.  
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2.  Optimizer Menus & Controls

In the Multiple Document Mode, the user is provided
with a Optimizer Problem Window that contains the
File, Viewand Tool Menus as illustrated in Figure 4.
The File Menu is similar to the File Menu in the
Document Windows for the Single Document Mode.
There are standard commands for opening, closing
and saving Optimizer Problem files.  An Optimizer
Problem may contain multiple beamline Model
Documents, but is saved as a single PBO Lab file.
The View Menu has commands for opening the
optimizer output files in Text Editor Windows for
each of the optimization engines.  The Optimizer
Submenus in the Tools Menu contain commands to
run Optimization Problems and commands that
access user interface windows for Optimization
Constraints and variables, application-specific stored
output parameters and for specifying variable order
and optimizer options.  Submenus are provided for
each of the optimization engines in the Tools Menu.
These commands are described in the Optimizer
Commands Section of this Supplement.  

In the Multiple Document Mode, the
user is provided with a Optimizer
Problem Window that contains the
File, View and Tool Menus for the
Optimizer.  

The Optimizer Tools Menu contains
commands to set up and run
Optimization Problems using any of
the optimization engines.  

Figure 4.  Menus in the Optimizer Problem Window.  
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Optimizer File Menu

The commands in the File Menu of the Optimizer
Problem Window are to create New Optimizer
Problems, Openexisting Problems, Closethe current
Problem Window and Save the current Optimizer
Problem.  These commands do not refer to beamline
Model Documents in the Optimizer Problem.  For
example, the Newcommand will create and open a
new untitled Optimizer Problem Window.  In order
to  create a new beamline Model Document Window
in the current Optimizer Problem Window, use the
Button Bar in the Problem Window.  Refer to the
Optimizer Button Bar Section in this Chapter.  

The Print and Print Setupcommands are standard
File Menu commands that are identical to the File
commands in the Document Window.  The Import
and Recent Files Submenus are also identical to the
commands in the File Menu of the Document
Window.  Refer to the Menu BarSection in the User
InterfaceChapter of the main PBO Lab User Manual
for a description of these commands.  

The last command in the File menu of the Problem
Window is Exit, which is used to close all application
windows and quit the PBO Lab application.  

The File Menu of the Optimizer
Problem Window has commands to
create New Optimizer Problems,
Open existing Problems, Close the
current Problem Window and Save
the current Optimizer Problem.
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Optimizer View Menu

The commands in the View Menu of the Optimizer
Problem Window are used to open the native output
and summary files produced by each of the
optimization engines.  There are preferences that can
be set in the Optimizer Options Window that will
cause these files to be opened automatically after
executing the optimizer.  Refer to the Optimizer
Options Section in this Chapter.  The View
commands do not execute optimization, they simply
allow output files previously generated to be viewed
in PBO Lab Text Edit Windows.  

The View Menu is used to open the
native output files produced by the
different optimizer engines.  

Optimizer Tools Menu

The commands in the ToolsMenu of the Optimizer
Problem Window are used to setup and run
Optimization Problems using any of the optimization
engines.  There are also commands to access user
interface windows that list Optimization Constraints
and variables, application-specific stored output
parameters and allow specification of variable order
and optimizer options.  

The Tools Menu is divided into four groups of
commands.  The first group contains the main
execution submenus for each of the optimizer
engines.  The Run...commands in each submenu are
used to start the optimization process using the
selected engine.  The NPSOL and MINOS submenus
also have commands for opening Optimizer
Constraint Windows and Watch Value Setup
Windows.  The LSSOL submenu contains a
command for accessing the LSSOL Constraints
Windows but does not provide a Watch Values Setup
command.    

The commands in the Tools Menu of
the Optimizer Problem Window are
used to setup and run Optimization
Problems.  Submenus are provided
for each of the optimizer engines.  

PBO Lab 2.2 User Manual Supplement: Optimization Module (DRAFT)

11



The second command group in the Tools Menu has
one command that is used to access the Optics
Calculation Options Window.

The third group of commands in the Tools Menu
provides access to dynamic list windows for user
specified Optimization Variables and application-
specific Stored Output Parameters.  As well as a
command for opening the Variable Order Window.
Unlike Optimization Constraints, which are specific
to each optimization engine, the Optimization
Variables and Stored Output Parameters are selected
in the beamline Model Document(s) and are not
specific to a particular optimization engine.  The list
windows for Optimization Variables and Stored
Output Parameters provide a convenient list of all
the variables and stored parameters that have been
selected in the beamline model document(s).
Double-clicking an entry in a list window will open
the Piece Window in the beamline model for that
selection.  

The last command group in the Tools Menu has two
commands.  The Restore Previous Variables
command is used to restore Optimization Variables
in the beamline model to previous values (values
prior to the last optimization process).  The last
command in the Tools Menu opens the Optimizer
Options Window.  This window contains three tab
panels (one for each of the optimizer engines)
containing native optimization options as well as
some PBO Lab user interface Preferences.  

Optics Calculation Options Window

Optimization Variables List Window 

Stored Output Parameters
List Window

Variable Order Window

Restore Previous Variables
Command

Optimizer Options Window
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Optimizer Button Bar

The Button Bar of the Optimizer Problem Window
provides controls for a variety of problem setup
features as illustrated in Figure 5.  The first button
saves the Optimization Problem file.  One or more
beamline Model Documents from other Optimization
Problem files can be added to the current Optimizer
Problem with the second button.  New Model
Documents can be added to the Optimization
Problem with the third button and may be renamed
with the fourth button.  Cut, Copy and Paste buttons
allow Model Documents to be moved between
Optimization Problem files and the Delete button
removes a Model Document from the Optimization
Problem.  

The Button Bar of the Optimizer
Problem Window provides controls
for a variety of problem setup
features.  

Create a new untitled model Document in the Optimization Problem.

Cut selected model Document from Optimization Problem.

Copy selected model Document to the clipboard for 
subsequent Paste into Optimization Problem.

Paste a new model Document into the  Optimization Problem.

Delete selected model Document from the Optimization Problem.

Save PBO Lab file.

Add model(s) from another Optimization Problem or 
from another model Document file.

Rename selected model Document.

Figure 5.  Optimizer Problem Window Button Bar Controls.  
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3.  Optimization Variables

Optimization Variables are selected in Special
Parameter Settings Windows as illustrated in Figure
6.  

Select a Parameter as an Optimization 
Variable and Specify the Limiting 
Bounds in the Optimizer Tab Panel.

Access Optimization-Specific Parameter 
Settings in the Optimization Tab Panel of 

the Special Parameter Setting Window.

Double-Click the Piece icon 
to open the Piece Window 
for that Beamline Element.

Open the Special Parameter Settings 
Window with the "S" Button for the 

Desired Parameter.

Figure 6.  User Interface for Selecting Optimization Variables.  
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The user interface for selecting Optimization
Variables is the same as that used to select fitting
variables for the different Application Modules.
Input parameters for beamline elements are accessed
by double-clicking Piece icons in the beamline model
of Document Windows.  Figure 6 illustrates opening
a Quadrupole Piece Window and selecting the
Magnetic-Field Gradient Parameter as an Optimizer
Variable.  

Applicable parameters have Special “S” buttons that
are used to access Special Parameter Settings
Windows.  An example of a Special Parameter
Settings Window is shown in Figure 6.  The “S-
Windows” have tab panels that provide access to
application-specific options for installed Application
Modules and Tools.  The tab panel for the
Optimization Tool is shown in Figure 6.  It provides
a check box that is used to toggle the selection of the
parameter as an Optimization Variable, and has
inputs for specifying limiting bounds on the variable.
The initial value for the variable is specified directly
in the Piece Window.  

Double-click an icon in the beamline model to open a
Piece Window and press the “S” button to the right
of the desired parameter in the Piece Window.  This
will open the corresponding Special Parameter
Settings Window (“S-Window”) for that parameter.
Select the Optimizertab panel in the S-Window and
click on the Optimizer Variable check box.  The
Optimizertab panel is also used to specify the lower
and upper limits that the optimizer will use as
bounds for the variable.  At the top of the S-Window
is a Symbolic Parameter Name field that will
automatically be assigned when the Optimizer
Variable check box is selected.  You may enter your
own symbolic name for the Optimizer Variable in
this field, but the variable must be named.

The user interface for selecting
Optimization Variables is the same
as that used to select fitting
variables for the different Application
Modules.  

Optimization Variables are selected
in the Special Parameter Settings
Windows for beamline model Pieces.  

Optimization Variables must be
named at the top of the S-Window.  A
Symbolic Parameter Name will be
automatically assigned when the
Optimizer Variable check box is
selected or you may enter your own
name.  
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Variables List Window

The Tools menu provides a command for opening
the Variables List Window, illustrated in Figure 7,
which lists all of the Optimization Variables for the
entire Optimization Problem.  

All of the Optimization Variables selected over all
the beamline models in an Optimization Problem are
displayed in the Variables List Window.  Double-
clicking an entry in the List Window will open the
Piece Window for that selection as illustrated in
Figure 7.  This provides quick access to all of the
Optimization Variables specified for beamline and
across multiple beamline models as well.  

The Tools menu provides a command
f o r o p e n i n g t h e O p t i m i z a t i o n
Variables List Window.

For Optimization Problems with
multiple beamline models, the
Variables List Window includes all
Variables from all of the beamline
Model Documents included in the
Optimizer Problem Window.  

Optimization Variables for all beamline model 
Documents in the Optimization Problem are 

organized in a cumulative List Window

Double-click an entry in the List 
Window to access a specific 

Optimization Variable

Figure 7.  Optimization Variables List Window.  
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Variable Order Window

The Variable Order Window, illustrated in Figure 8,
is accessed from the Tools Menu and is used to
change the order that will be used to setup the
Optimizer native inputs.  Variables are listed by the
order in which they are selected, but this order may
be changed in the Variable Order Window.  

The Variable Order Window can be used to change
the order in which Variables are specified for the
Optimization engine.  It may be desirable in some
cases to start the problem with a different variable
order.  Refer to the User’s Guide for NPSOLfor a
description of variable order.  

The Tools menu provides a command
for opening the Optimizer Variable
Order Window.

The Variable Order Window can be
used to change the order in which
Variables are specified for the
Optimization engine.  

After selecting an entry in the list of Optimizer 
Variables, use the up and down arrow controls 

to move the selection in the list

Figure 8.  Changing the Order of Optimization Variables.  
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4.  Stored Output Parameters

Stored Output Parameters are application-specific
diagnostic output results that are defined with a user-
specified name and can be used in the definition of
algebraic expressions for Nonlinear Constraints and
the Optimization Objective Function.  

Both Linear and Nonlinear Constraints, as well as
the Optimization Objective Function are defined as
algebraic expressions of user specified Optimization
Variables and application-specific Stored Output
Parameters.  The Optimizer Tool can use
application-specific Stored Parameters for the
definition of Nonlinear Constraint Expressions and
for defining the Objective Function.  However,
Linear Constraints can only be specified in terms of
Optimization Variables selected from beamline
model parameters, not in terms of application-
specific Stored Output Parameters.

Stored Parameters are specified at specific locations
in the beamline model(s) using a Marker or Final
Piece as illustrated in Figure 9. Marker Pieces are
inserted into the beamline model by dragging the
Piece icon from the Palette Bar to the location in the
beamline where the value of a Stored Output
Parameter should be collected (TRANSPORT).  A
Final Piece may also be used for this purpose, since
it is a special case of the Marker Piece that is
typically used at the end of a beamline model
(TRANSPORT and TRACE 3D).  

Information regarding the Marker Piece can be
found in the main PBO Lab User Manual.
Individual Application Module Manual Supplements
contain additional information regarding the Marker
Piece and the specification of Stored Parameters for
each Module.

Stored Parameters are specified at
specific locations in the beamline
model(s) using a Marker or Final
Piece.

The Optimizer Tool can use
application-specific Stored Output
Parameters for the definition of
Nonlinear Constraint Expressions
and for defining the Objective
Function.  

Stored Output Parameters are
specified at specific locations in the
beamline model(s) using Marker or
Final Pieces.  
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Drag a Marker Piece to any 
location in the beamline 
model to specify Stored 

Parameters at that location

Double-click the Marker 
Piece icon to open the 
Marker Piece Window

Select from the installed 
Application Modules with the 
Application Context switch

Figure 9.  Marker and Final Piece Windows.  
The Marker and Final Piece Windows are
application-independent.  They have an Application
Context switch that is used to open the appropriate
application-specific user interface window for
Constraints, Diagnostics or Stored Parameters.
There are three panels in the Marker (and Final)
Piece Windows.  The Open buttons in the three
panels will open the application-specific user
interface window for the current setting of the
Application Context switch.  

The Application Context switch in the
Marker Piece Window is used to
open the appropriate application-
specific user interface window for
TRANSPORT Stored Parameters.  
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For example, when the Application Context is set
for the TRANSPORT Application Module, then the
Open button in the Stored Parameters panel will
open the application-specific Transport Stored
Parameters Window as illustrated in Figure 10.  

The scrolling lists in each of the three panels of the
Marker Piece Window display all selections,
independent of the Application Context, and
individual selections may be deleted with the
Removebuttons without changing the Application
Context switch or opening the application-specific
user interface window.  

The Marker and Final Pieces are
used to specify location-specific
Constraints, Diagnostics and Stored
Parameters for individual Application
Modules.  

The Application Context switch 
determines which windows will be 

opened for Constraints, Diagnostics 
and Stored Parameters

TRANSPORT Output Parameters are 
Selected and Named in the Transport 

Stored Parameters Window

The Open Button in the Store Panel of the Marker 
and Final Piece Windows provides access to the 

Transport Stored Parameters Window

Figure 10.  Application-Specific Windows Accessed from Marker Pieces.  
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The Constraints panel and Diagnostics panel of the
Marker and Final Piece Windows are used for
application-specific Fitting Constraints and Output
Diagnostics.  The Output Diagnostics are used to
specify various application-specific output data at the
location of the Marker in the beamline model and
are not required for optimization.  The Constraints
are also application-specific and are only required
for the specification of a hierarchical Optimization
Problem in which local application-specific fitting is
combined with higher level optimization.  

The Stored Parameters panel in the Marker Piece
Window is used with the Optimizer Tool to define
application-specific Stored Output Parameters that
will be used in the definition of the Optimization
Objective Function and for use in Nonlinear
Optimization Constraints.  Stored Parameters are
selected and defined by a symbolic name which can
then be used in algebraic expressions of the
Objective Function and Nonlinear Constraints.  The
values for these application-specific Output
Parameters are calculated by the Application Module
and collected at the location of the Marker (or Final)
Piece in the beamline model.  The different types of
Stored Output Parameters that may chosen are
dependent on the selected Application Module.  

TRANSPORT Stored Parameters

The TRANSPORT Application Module supports a
variety of Stored Output Parameters that are listed in
Table 1.  The user interface for selecting
TRANSPORT Stored Output Parameters is user
friendly and does not require specific knowledge of
all the TRANSPORT keywords for storage
parameters.  

A p p l i c a t i o n - s p e c i f i c F i t t i n g
Constraints and Diagnostics are not
required to define an Optimization
Problem.  

Application-specific Constraints are
not the same as Optimization
Constraints.  However, a hierarchical
Optimization Problem can be
formulated in which local application-
specific fitting constraints are
combined  with  the  higher  level
optimization constraints used by the
Optimization Tool.  

Stored Parameters are selected and
defined by a symbolic name which
can then be used in algebraic
expressions of  the Objective
Function and Nonlinear Constraints.  
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Table 1.  TRANSPORT Stored Output Parameters.

Correlation Matrix (i,j =1,6) Keyword
Beam Correlation Matrix Element C ij

Beam Matrix (i,j =1,6) Keyword
Reduced Sigma Matrix Element S ij

Transfer Matrices (i,j,k,l =1,6) Keyword

1st-Order Transfer Matrix Element Rij

2nd-Order Transfer Matrix Element T ijk

3rd-Order Transfer Matrix Element Uijkl

Transfer Matrices (i,j,k,l =1,6) Keyword

1st-Order Auxiliary Matrix RAij

2nd-Order Auxiliary Matrix TA ijk

3rd-Order Auxiliary Matrix UAijkl

Beam Centroids Keyword
Horizontal Beam Centroid Position XC

Horizontal Beam Centroid Angle XPC
Vertical Beam Centroid Position YC

Vertical Beam Centroid Angle YPC

Longitudinal Beam Centroid Position DLC
Longitudinal Beam Centroid Angle DELC

Beam Envelopes Keyword
Horizontal Beam Half Width XBEAM

Horizontal Beam Half Angle XPBEAM
Vertical Beam Half Width YBEAM

Vertical Beam Half Angle YPBEAM

Longitudinal Beam Half Width LBEAM
Longitudinal Beam Half Angle DELBEAM

Floor Coordinates Keyword
Beamline Accumulated Length L

Floor Coordinate X Value XFLOOR
Floor Coordinate Y Value YFLOOR

Floor Coordinate Z Value ZFLOOR

View Reference Trajectory Angle YAW
Reference Trajectory Horz. Angle PITCH

Net Rotation Angle about Trajectory ROLL

Elevation ELEVATION

Lattice Functions Keyword

Accelerator Function BetaX BETAX
Accelerator Function AlphaX ALPHAX
Accelerator Function BetaY BETAY
Accelerator Function AlphaY ALPHAY

Accelerator Function EtaX ETAX
Accelerator Function DeltaX DETAX
Accelerator Function EtaY ETAY
Accelerator Function DeltaY DETAY

Figure 11 illustrates the different controls and pop
ups in the Transport Stored Parameters Window.
All of the selections listed in Table 1 can be made
from the various controls and pop ups in the
Transport Stored Parameters Window, without
having to know the TRANSPORT keywords.  
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The symbolic name for 
Stored Parameters can be 

specified by the user.

A complete range of matrix 
elements can be selected with the 

radio buttons and the matrix panel.

The application-specific Keyword 
is generated by the user interface 

when a selection is made.

Figure 11.  TRANSPORT Stored Output Parameters Window.  

Refer to the TRANSPORT Documentation for a
technical description of the TRANSPORT Output
Parameters.  The PBO Lab User Manual
Supplement for the TRANSPORT Application
Module also describes the selection of location-
specific Stored Output Parameters in the Marker
PieceSection.  
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TRACE 3D Stored Output Parameters

Specifying Stored Output Parameters for the
TRACE 3D Application Module is similar to
selecting  TRANSPORT Stored Parameters, except
TRACE 3D only supports diagnostic outputs at the
end of a beamline model.  To define Stored
Parameters for TRACE 3D, a Final Piece must be
placed at the end of the beamline in the Model
Document Window.  Double-clicking the Final Piece
in the beamline will open the Final Piece Window as
illustrated in Figure 12.  

The Final Piece is used at the end of
a beamline model to specify Stored
Output Parameters for the TRACE
3D Application Module.  

A Final Piece placed in the 
beamline model is used to access 
Stored Output Parameters for the 
Trace 3D Application Context

Stored Parameters are 
displayed in the Store 

Panel of the Final 
Piece Window

Figure 12.  Using the Final Piece to specify TRACE 3D Stored Parameters.  
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The Application Context must be 
set to TRACE-3D in order to open 
the Trace 3D Stored Parameters 
Window from the Final Piece

Stored Parameters are displayed in 
the Store Panel of the Final Piece 
Window. Open button in the Store 
panel is used to access the Trace 3D 

Stored Parameters Window

Figure 13.  Opening the Trace 3D Stored Output Parameters Window.  

The PBO Lab Final Piece is actually a special case of
the Marker Piece and double-clicking it will open the
same type of Piece Window as the Marker Piece
(Figure 10).  Refer to the PBO Lab User Manual
Supplement for the TRACE 3D Application Module
for a more detailed description of using the Final
Piece to specify Trace 3D Matching Types
(Constraints), Diagnostics and Stored Output
Parameters.  Figure 13illustrates opening the
TRACE 3D Stored Parameters Window from a
Final Piece that has been placed at the end of the
beamline model.  Note that Application Context must
be set to TRACE 3D in the Final Piece Window in
order to open the Trace 3D Stored Output
Parameters Window.  
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The symbolic names for 
Stored Parameters can be 
specified by the user and 

are used in Optimizer 
Constraint Expressions

A complete range of matrix 
elements can be selected with the 

radio buttons and the matrix panel.

The application-specific 
Keyword is generated by 
the user interface when a 

selection is made

Figure 14.  Specification of TRACE 3D Stored Output Parameters.  

The user interface for selecting Stored Output
Parameters is user friendly and does not require in
depth knowledge of the TRACE 3D code.  Figure 14
illustrates the different controls and pop ups in the
Stored Parameters Window for the TRACE 3D
Application Module.  All of the selections that are
listed in Table 2 can be made from the various
controls and pop ups in the Trace3D Stored
Parameters Window, without having to know all the
TRACE 3D keywords.  

Table 2 on the following page list all
of the TRACE 3D keywords for
Stored Output Parameters.  
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Table 2.  TRACE 3D Stored Output Parameters.  

Transfer Matrix (i,j,k,l =1,6) Keyword
1st-Order Transfer (R) Matrix Element Rij

Beam Matrix (i,j =1,6) Keyword
Reduced Sigma Matrix Element S ij

Beam Centroids Keyword

Horizontal Beam Centroid Position x beamc(1)

Horizontal Beam Centroid Angle x’ beamc(2)
Vertical Beam Centroid Position y beamc(3)

Vertical Beam Centroid Angle y’ beamc(4)

Longitudinal Beam Centroid Position zbeamc(5)
Longitudinal Beam Centroid Angle z’ beamc(6)

Longitudinal Parameters Keyword

Phi (deg) Phi

Energy (MeV) Energy
DP (deg) DP

DW DW

DZ (KeV) DZ
DP/P (MeV) DP/P

Beam Emittance Keyword

Horizontal Beam Emittance (x-x’) emito(1)

Vertical Beam Emittance (y-y’) emito(1)
Long. Emittance (Phase Energy) emito(3)

Longitudinal Beam Emittance (z-z’) Ez

Lattice Functions Keyword

Accelerator Function AlphaX beamo(1)

Accelerator Function BetaX beamo(2)
Accelerator Function AlphaY beamo(3)
Accelerator Function BetaY beamo(4)
Accelerator Function AlphaX beamo(5)

Accelerator Function BetaX beamo(6)
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Stored Parameters List Window

The ToolsMenu in the Optimizer Problem Window
provides a command for opening the Stored
Parameters List Windowwhich lists all of the stored
diagnostic output parameters for the entire
Optimization Problem.  This List Window is similar
to the Optimizer Variable List Window described
previously.  The Stored Parameters List Window,
illustrated in Figure 15, includes all Stored
Parameters for all of the beamline Model Documents
in the Optimization Problem.  The window includes
columns for the beamline Model name, the
Application Module (optics simulation code), the
Piece Label and the symbolic name (Storage Name),
as well as the application-specific keyword for each
Stored Parameter.  

The Optimizer Stored Parameters
List Window contains entries for all
beamline Model Documents in the
Optimization Problem.  TRANSPORT
Stored Parameters for a single
Beamline Model Document are
accessed from the TRANSPORT List
Windows Submenu in individual
Document Windows.  

Stored Output Parameters for all beamline model 
Documents in the Optimization Problem are 

organized in a cumulative list window

Double-click an entry in the list window to open 
the location-specific Marker or Final Piece

Figure 15.  Application-Specific Stored Output Parameters List Window.  

PBO Lab 2.2 User Manual Supplement: Optimization Module (DRAFT)

29



Double-clicking an entry in the List Window will
open the corresponding Marker Piece Window for
that parameter.  The Use column in the list window
allows Stored Parameters to be disabled without
actually removing them.  Clicking in the Usecolumn
of a Stored Parameter will toggle that entry on and
off.  The Value field in the Stored Parameters List
Window will contain values after the corresponding
optics code (Application Module) is executed,
otherwise the Value fields will be empty.  
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5.  Optimization Constraints
Optimization Constraints are defined separately for
each of the Optimization Engines (NPSOL, LSSOL
and MINOS).  The Optimization Constraints
Windows are opened from the Optimizer Submenus
of the Tools Menu in the Optimizer Problem
Window as illustrated in Figure 16.  The
Optimization Constraints Windows are identical for
NPSOL and MINOS.  These windows provide tab
panels for Linear and Nonlinear Constraints, as well
as a tab panel for specifying the Optimization
Objective Function.  

O p t i m i z a t i o n C o n s t r a i n t s a r e
s p e c i f i e d i n t h e O p t i m i z a t i o n
Constraints Window, which is
opened from the Tools Menu in the
Optimizer Problem Window.  

The Optimization Constraints 
Windows for each Optimization 

Engine are opened from the 
Optimization Submenus in the 

Tools Menu of the Optimization 
Problem Window

The Optimization Constraints 
Window has tab panels for Linear 
and Nonlinear Constraints and a 
tab panel for the Optimization 

Objective Function

All Optimization Variables 
are organized in a pop-up list

Figure 16.  Opening Optimization Constraints Windows.
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NPSOL and MINOS Constraints

The Optimization Constraints Windows are used to
define constraints in terms of Optimization Variables
and Stored Output Parameters.  User specified
Optimization Variables and Stored Output
Parameters are organized in pop-up lists to simplify
the definition of constraint algebraic expressions.  

By definition, Linear Constraints can only be defined
in terms of Optimization Variables.  However,
Nonlinear Constraints and the  Objective Function
can be defined with Optimization Variables and
Storage Parameters.  All Constraints include lower
and upper bounds.  The Nonlinear Constraint tab
panel and the Objective Function tab panel also
include a convenient Operators panel, which contains
a variety of mathematical operators and functions
that can be used in defining constraint expressions.
Figure 17 illustrates the main features of the
Nonlinear Constraints tab panels for NPSOL.  The
MINOS Nonlinear Constraints tab panel is identical
to the NPSOL example shown in Figure 17, but is
accessed from the Constraints command in the
MINOS Optimizer Submenu of the Tools Menu in
the Optimization Problem Window. 

A Constraint Expression can be typed directly into
the Constraint field at the top of the window, or the
pop ups and operators can be used to construct the
expression.  Defaults are provided for the lower and
upper bound values based on an option in the
Optimizer Options Window.  The Add Constraint
button is used to accept a Constraint Expression and
add it to the list at the bottom of the window.  A
constraint expression can be removed from the list
by selecting it with the mouse and pressing the
Delete Constraint button.  All constraints can be
deleted at once using the Clear Constraintsbutton.  

T h e O p t i m i z a t i o n C o n s t r a i n t s
Windows are used to define
constraint expressions in terms of
Optimization Variables and Stored
Output Parameters.

A Convenient Operators panel
provides a variety of mathematical
operators and functions for defining
algebraic constraint expressions.  

Constraint Expressions can be
typed in directly, or the pop ups and
operators can be used to construct
expressions.  
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Nonlinear Constraint Expressions are 
entered along with bounding limits in 

the Nonlinear Constraints panel

The Non-Linear Constraints tab 
panel includes a convenient 

Operators panel

Optimization Variables and Storage 
Parameters are organized in pop-up 
lists to simplify the definition of 
Algebraic Constraint Expressions

Multiple Constraint 
Expressions are listed at the 

bottom of each tab panel

Figure 17.  Nonlinear Constraints tab panel for NPSOL.  

The Optimization Objective Functions for NPSOL
and MINOS are defined in the Objective Function
tab panel of their respective Optimization
Constraints Windows.  Figure 18 shows the
Objective Function tab panel from the NPSOL
Constraints Window.  The MINOS Objective
Function tab panel is identical to the NPSOL
example shown in Figure 18, but is accessed from
the Constraints command in the MINOS Optimizer
Submenu of the Tools Menu in the Optimization
Problem Window. 

The Objective Function is defined in
terms of Optimization Variables and
Stored Parameters in the Objective
Function tab panel of the Constraints
Window.  
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An algebraic expression of the Objective Function in
terms of Optimization Variables and Stored
Parameters is entered in the text field at the top of
the tab panel.  The Objective Function tab panel
includes an Operators panel and pop-up lists for user
specified Optimization Variables and Stored
Parameters.  Button controls are provided to Setand
Clear the Objective Function with the current
Objective Function displayed at the bottom of the tab
panel.  

The Objective Function tab panel
includes an Operators panel and
pop-up lists for user specified
Optimization Variables and Stored
Parameters.  

The complete Objective Function is 
displayed in the Current Objective 

Function panel

An algebraic expression for the 
Objective Function is entered in the 
scrolling Objective Function panel

Multiple Objective Functions can be 
defined and will be listed at the bottom of 
the window, but only one function is used

The current Objective Function is 
selected with an "X" in the "Use" 

column at the bottom of the window 

Figure 18.  Objective Function tab panel for NPSOL.  
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LSSOL Constraints
LSSOL is a constrained linear least-squares and
quadratic optimization program.  Unlike the other
two optimization engines (NPSOL and MINOS),
LSSOL does not use Output Storage Parameters
captured from the various optics codes (Application
Modules) in the PBO Lab environment.  Constraint
expressions for LSSOL are linear and therefore can
not contain Output Storage Parameters.

The LSSOL Optimization Constraint Window is used
to specify constraint expressions in terms of selected
Optimization Variables in a beamline model.  User
specified Optimization Variables are organized in a
pop-up list to simplify the definition of algebraic
constraints expressions.  Figure 19 illustrates the
Linear Constraints tab panel of the LSSOL
Optimization Constraint Window.  

LSSOL does not utilize Output
Storage Parameters from PBO Lab
Application Modules to specify
Optimization Constraints.  

Specify constraint expressions for
LSSOL in terms of the selected
Optimization Variables in a beamline
model.

Multiple Constraint 
Expressions are listed at the 

bottom of each tab panel

Linear Constraint Expressions are 
entered along with bounding limits in 

the Linear Constraints panel

Optimization Variables are 
organized in a pop-up list to 
simplify the definition of 
Constraint Expressions

The Use column allows Constraint 
Expressions to be toggled on or off 

without deleting the Expression 

Figure 19.  LSSOL Linear Constraints.  
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A Constraint Expression can be typed directly into
the Constraint field at the top of the window, or the
pop up for Optimization Variables can be used to
construct the expression.  The Set button is used to
make a selection from the Variable pop-up. Defaults
are provided for the lower and upper bound values
based on an option in the Optimizer Options
Window.  The Add Constraint button is used to
accept a Constraint Expression and add it to the list
at the bottom of the window.  A constraint
expression can be removed from the list by selecting
it with the mouse and pressing the Delete Constraint
button.  All constraints can be deleted at once using
the Clear Constraintsbutton.  

The Optimization Objective Function for LSSOL is
defined in the Objective Function tab panel of the
Optimization Constraints Window, illustrated in
Figure 20  

"m" defines the number of 
Optimizer Constraints

"c" array corresponds to the 
number of Variables (n)

"b" array corresponds to the 
number of Constraints (m)

LSSOL supports a variety 
of Optimization Problem 
Types that are organized 

in a pop-up list

"A" Constraint Maxrix 
(m x n)

Data is entered in to the three 
tables (c array, A matrix or b array) 
using the row of controls at the top 

of the Objective tab panel

Figure 20.  Optimization Objective Function for LSSOL.  
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LSSOL supports a variety of Optimization Problem
Types which are described in the User’s Guide for
LSSOL.  The Optimization Type is selected with the
Problem Type pop-up in the Objective tab panel of
the LSSOL Constraints Window, as illustrated in
Figure 20.  

The Objective function for LSSOL is specified using
the “c” array, corresponding to the number of
O p t i m i z a t i o n V a r i a b l e s , t h e “ b ” a r r a y ,
corresponding to the number of constraints and the
“A” Constraint Matrix.  Data is entered into these
three tables using pop-up controls to specify the row
and column in the “A” Matrix and then entering the
desired value in any of the input fields for “b”, “A”
or “c”.  After making a selection using the row and
column pop-ups, subscripts will appear next to each
of the text fields.  Use the Enter key to accept a
value from a text input field and it will be updated in
the corresponding table.  

Refer to the User’s Guide for LSSOL for a
description of the different types of problems that
can be examined with LSSOL and the specification
of constraints and the objective matrix.  
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5.  Options & Watch Values
The Tools Menu in the Optimizer Problem Window
provides commands for opening the Watch Values
Setup Windows for the NPSOL and MINOS
optimization engines.  Figure 21 illustrates opening
the Watch Values Setup Window for NPSOL from
the NPSOL Submenu in the Tools Menu.  This
Watch Values Setup Windows is used to select the
Optimization Variables and Constraints that will be
displayed during an NPSOL Optimization process.
The MINOS Watch Values Setup Window is opened
from the MINOS Submenu in the Tools Menu.
LSSOL does not support watch values.  

The Tools Menu in the Problem
Window  provides  commands  for
opening the Watch Values Setup
Windows for the NPSOL and MINOS.  

Select from the entries on the left side of 
the window and use the arrow buttons to 

make a Watch Value Selection

Optimization Variables and 
Constraints for all beamline model 

Documents are listed in the scrolling 
lists on the left-hand side of the 

Watch Values Setup Window

To display the Watch Window 
during Optimization, the 

check box must be selected 

Figure 21.  Selecting Watch Values for NPSOL Optimization. 
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Watch Values Setup Windows

The Watch Values Setup Windows (for NPSOL and
MINOS) are divided into Variables and Constraints
panels and the Constraints panel is further divided
into Linear and Nonlinear Constraints.  Setup Watch
Values by selecting an entry from the lists of
Variables and Constraints on the left side of the
window and pressing the right arrow button (in the
middle of the window) to copy the selection to the
lists on the right side.  Entries can also be removed
from the watch lists on the right side of the window
by selecting them and pressing the left arrow button.
The example shown in Figure 21 only contains
Variables and Nonlinear Constraints, so the Linear
Constraints list is empty.  

In order to display the selected Watch Values during
the Optimization process, the check box at the top of
the window must also be selected.  To disable the
display of the Watch Window without deleting any
of the selected Watch Values, un-check the box.  If
there are no Watch Values selected and/or the check
box to display the Watch Window has not been
checked, then there will be no output until the
Optimization process has completed and the native
output from the Optimizer is displayed.  

Watch Values are selected from the
lists of Variables and Constraints on
the left side of the window and added
to the Watch lists on the right side of
the window.

Watch Values must be selected and
the “Display Watch Window” check
box must also be checked in order to
get the dynamic Watch Window to
display the results during the
Optimization Process.  
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Optics Calculation Options

The Optics Calculation Options Window, shown in
Figure 22, is used to select the type of optics
calculation that will be used with the different
Application Modules (TRANSPORT, TRACE 3D)
that may be used in the optimization process.  The
Optimizer Tool automatically runs an Application
Module to get values for application-specific Stored
Output Parameters that have been selected in the
beamline Model Document Window.  These values
are then used in the evaluation of Optimization
Constraints and the Optimization Objective (merit)
function.  Each time Optimization Variables are
changed, the Application Module is executed in
order to update the Stored Output Parameters.
Optics Calculation Options are provided so that
specific selections can be specified for automatic
execution during the optimization process. 

The Optics Calculation Options
Window is used to select the
simulation (Application Module) and
the calculation option that will be
used during the Optimization
process.  

After selecting the Simulation Type
for a beamline Model Document, the
Execution Type must be selected.  

Each Beamline Model Document in the 
Optimization Problem can have an independent 
Symulation Type (Application Module) and an 

Execution Type (Application Command)

First select the Beamline Model Document 
and the Symulation Type, then the 

Execution Type options will be activated

Figure 22.  Specifying Optics Calculation Options.  
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Application Modules have different selections in the
Optics Calculation Options Window for specifying
the command that will be executed at each iteration
in the optimization process.  For example, the
T R A N S P O R T A p p l i c a t i o n M o d u l e i n c l u d e s
selections for running TRANSPORT with or without
Fitting, as illustrated in in Figure 22.  

There are three panels in the Optics Calculation
Options Window.  The Modelspanel on the left side
of the window contains a list of all the beamline
Model Documents in the Optimizer Problem.
Clicking on a Model Document in this panel will
select that model and activate the middle panel
labeled Simulations.  The Simulationspanel contains
a list of applicable Application Modules.  After
selecting an Application Module from this list, a
third panel will be activated on the right side of the
window that contains options for different optics
calculations that can be used with the selected
Application Module.  For example, a hierarchical
optimization can be carried out using the
TRANSPORT calculation option: Run Transport
With Fitting to perform a localized fit with
TRANSPORT, while a global optimization is
performed with the optimization engine.  

The Optimization Tool determines which
Application Modules need to be executed based on
the selection of Stored Output Parameters.
However, the selections in the Optics Calculation
Options Window specify what type of calculation
will be performed for each beamline Model when
the Application Module is executed.  

To specify an Optics Calculation
Option, select a beamline Model
Document from the Models panel.
Then select an Application Module
from the Simulations panel.  Now
select from the available options in
the Execution Type panel.  

Optimization Problems that contain
multiple beamline Model Documents
can use different Application
Modules and/or different calculation
options for each Model Document.  
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Optimizer Options Window
The Options command in the Tools Menu of the
Optimizer Problem Window opens the Optimizer
Options Window, as illustrated in Figure 23  This
window contains a tab panel for each of the
Optimization engines.  Each tab panel contains both
Options and Preferences.  The Options panel is used
to set options that are passed directly to the
Optimization engine.  The Preference panel is used
to select different output preferences for the
Optimization Tool in PBO Lab.  

The selections in the Optimizer Options Window are
those most commonly used.  However, it is also
possible to use the native options file of the
individual optimization programs to specify any
option described in the different user manuals.  To
use the native options file, check the box for “Use
NPSOL.OPT Options File” in the Options panel of
the window.  Using the native options file will
overwrite any options selected in the Optimizer
Options Window, but will not effect Preference
choices.  Refer to the User’s Guide for NPSOLfor a
description of individual options. 

The Options command in the Tools
Menu of the Optimizer Problem
Window opens the Optimizer Options
Window.  

PBO Lab Preferences for the 
Optimization Tool are also 

included in the Options Window

Figure 23.  Optimizer Options Window.  
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Common Options are included in 
the Optimizer Options Window, 

but Options may also be specified 
using the native Options File for 
each of the Optimization Engines

PBO Lab Preferences 
for the Optimization 
Tool are also included 
in the Options Window

The Optimizer Options Window 
contains tab panels for each of the 

Optimization Engines

Figure 24.  Options tab panels for NPSOL, LSSOL and MINOS.  
The PBO Lab preferences for the Optimization Tool
differ slightly for the three Optimization Engines.
NPSOL includes preferences to automatically open
the native NPSOL Output and Summary files, as
well as a preference for generating a low level
diagnostic output file.  LSSOL has one preference
for automatically opening its native Output file.
LSSOL does not include Summary and Diagnostic
output.  MINOS preferences include automatically
opening native Output and Summary files.  There is
no low level diagnostic output for MINOS.  
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7.  Running an Optimization
Problem

An Optimization Problem is defined when
Optimization Variables have been selected in the
beamline model and Optimization Constraints have
been specified for the targeted Optimization Engine.
Watch Values must be setup in order to view the
optimization process but they are not required to
define an Optimization Problem.  The optimization
process is started using one of the Run...commands
located in the Optimizer Submenus in the Tools
Menu of the Optimizer Problem Window as
illustrated in Figure 25.  

The optimization process is started
using one of the Run... commands
located in the Optimizer Submenus
in the Tools Menu of the Optimizer
Problem Window.

Each Optimization Engine is executed 
from its own Submenu in the Tools Menu 

of the Optimization Problem Window

Figure 25.  Run an Optimization Problem from the Problem Window Tools
Menu.  

When the optimization process is complete the native
output files are automatically opened in PBO Lab
Text Edit Windows.  The preferences for
automatically opening the native output files are
found in the Optimizer Options Window.  If these
preferences are not checked then the output files will
still be generated, but they will not be automatically
opened following execution.  Previously generated
output files may be opened any time using the View
Menu commands in the Optimizer Problem Window.
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Optimizer Watch Window

The Optimizer Watch Window is opened when the
Run Optimizer Command is selected in the Tools
Menu, if Watch Values have been selected in the
Watch Values Setup Window.  If no Watch Values
have been selected or the Display Watch Window
check box is not selected, then the Watch Window
will not be opened during the Optimization process.
Figure 26 illustrates running the Optimizer from the
Problem Window Tools Menu.  

If no Watch Values have been
selected or the Display Watch
Window check box is not selected,
then the Watch Window will not be
opened during the Optimization
process.  

Optimization Constraints are displayed 
with dynamic gauges showing the 

current value and the limiting bounds

Application-specific Stored Parameters 
are calculated by the Application Module 
at each step in the optimization process

The Optimizer Output file 
is automatically opened in 

a Text Edit Window

User specified Optimization Variables are 
displayed with dynamic gauges showing 
the current value and the limiting bounds

The Objective Function is displayed 
with the current value calculated by the 

Optimization Engine at each step

Figure 26.  Optimizer Watch Window and NPSOL Output Window.  
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During optimization the Watch Window is used to
monitor the Objective Function as well as
Optimization Constraints and Variables.  This
window dynamically displays the optimization
progress during execution.  Display gauges that are
bound by the user specified limits are updated at
each step in the optimization cycle to illustrate the
current values for Optimization Constraints and
Variables.  A display at the top of the window also
shows the current value for the Objective Function at
each step in the optimization process.  An example of
the Watch Value Window is shown in Figure 26.
The Optimization Variables are used to update the
beamline model(s) during the optimization process.
Any application-specific Stored Parameters are
calculated by the respective Application Module.
The Objective Function is evaluated by the
Optimizer Tool and its current value is displayed at
the top of the Watch Values Window.  When the
process is complete, the native Output and Summary
files are automatically opened in a Text Edit
Window as illustrated in Figure 26.  

In some cases the Optimizer will not find an optimal
solution on the first execution.  The “Li01-
LMATCH.UnfitQuads.pbol” Optimization Problem
used in this Supplement is an example.  The optimal
solution for this problem took two executions of the
Optimizer to get the results shown in Figure 25.  

Following the execution of the Optimizer,
Optimization Variables selected in the beamline
model(s) of the Optimization Problem will be
altered.  This is true even if the optimal solution is
not found.  The Optimizer uses the Application
Module that has been selected in the Simulation Type
Window to evaluate the application-specific Stored
Output Parameters each time the Optimization
Variables are modified.  

The Watch Window is used to
dynamically display the optimization
progress during execution.  

When the Optimization process is
complete, the NPSOL Output file is
automatically opened in a Text Edit
Window.   

Some problems may require multiple
executions of the Optimizer to find
an optimal solution.  

Each iteration in the Optimization
process updates the beamline
model(s) with new Variables chosen
by the Optimizer so that the Stored
Output  Parameters  can  be
recalculated by the Application
Module.
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At each step in the Optimization process the
beamline model(s) are updated with the Variables
chosen by the Optimizer, so that the Stored Output
Parameters can be recalculated by the Application
Module.  Consequently, the beamline model(s) will
be modified with respect to the Piece Parameters that
have been chosen as Optimization Variables.  
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